2007-08-04

Top > Weblog > 2007-08-04

プラグイン更新

昨日キャッシュ利用プラグインの処理を更新しましたが、さらに れぶろぐ - PukiWiki 用プラグイン geshi.inc.php, highlighter.inc.php Ver.1.1 を公開 を参考にプレビューでもキャッシュを更新するようにしました。忘れないうちに。

dump2html のブロック型はプレビューで動作する必要はないのでそのままです。Thanks!

GPL3

ところで昨日、monobook を更新していて気付きましたが、

が以前から物議を醸し出していた GPL3 になっていますね。拙作のプラグインでは上のアドレスにリンクを貼っていましたが、lunt さんのように

に変更したほうがいいのかな。GPL3 と GPL2 は非互換とのことなので、PukiWiki 本体が GPL2 であればプラグインは GPL3 にはできない(すると利用してもらえない)ってことでいいのですよね?

http://www.gnu.org/licenses/rms-why-gplv3.html

there is no legal way to combine code under GPLv2 with code under GPLv3 in a single program.